PortalHomeCalendarGallerySearchMemberlistRegisterLog in
Warning! Donations are getting less and less. Your support is needed now! Donate to keep the servers alive!

Share | 
 

 server lags

View previous topic View next topic Go down 
AuthorMessage
myljach
Running dead
Running dead
avatar


PostSubject: server lags   2018-09-08, 22:33

on server 2018, reported by players, restart may help
Back to top Go down
View user profile https://steamcommunity.com/profiles/76561198009159427/
alBert2000
sprinting dead
sprinting dead
avatar


PostSubject: Re: server lags   2018-09-09, 08:13

Need more info.

Who reported it?
Which map? (often custom campaigns are the problem and then there is no solution)
When did it happen?
Did all players lag or only certain players?

I just connected quickly and the server seems to be fine on c1m1_hotel map.

If it was on "Deadly Dispatch" campaign there are some reports about lags on gamemaps (https://www.gamemaps.com/details/2443) e.g. like this:

"... Big lag for those people who can only run Left 4 dead 2 with minimum requirements ..."

and

"... However, there was a small fps optimization issue on chapter 1 ..."
Back to top Go down
View user profile
myljach
Running dead
Running dead
avatar


PostSubject: Re: server lags   2018-09-09, 11:34

All player was laggin including me on Deadly dispatch. After finish, DBF notice in dead center same lags, me not, but if anything exist, u solve it by servers maintenance today

CU
m.
Back to top Go down
View user profile https://steamcommunity.com/profiles/76561198009159427/
Snakecharmed
Walking dead
Walking dead
avatar


PostSubject: Re: server lags   2018-11-04, 05:08

I've noticed some lag on all servers on votemap switch, but 18 is especially slow right now. I was testing the updated Dark Wood Extended and it failed to load the campaign twice upon votemap switch and also failed to load the next map several times after closing the saferoom door.

21 seems to load the campaign at a normal speed, but there were a few occasions today while testing campaigns that I noticed HLstatsX time out and all the servers were temporarily unresponsive to the game client.

Back to top Go down
View user profile
alBert2000
sprinting dead
sprinting dead
avatar


PostSubject: Re: server lags   2018-11-04, 05:40

It could be some regular Linux server update and maintenance stuff at that time of the day.
Please use "thetime" command to get the server time when that happens again.
Thanks
Back to top Go down
View user profile
Snakecharmed
Walking dead
Walking dead
avatar


PostSubject: Re: server lags   2018-11-04, 06:04

Thanks, I will remember to include the timestamp in future reports.

Here are some select timestamps with map loading issues from the activity log:

Connection dropped between maps:

Last kill before closing saferoom door on DW:E Map 1, connection dropped during kill summary screen:
2018-11-04 00:58:00 Kill I killed BOT-Jockey with knife. alServ2018 Coop dw_woods


These next three entries are consecutive:

Auto-disconnect from votemap switch:
2018-11-04 03:06:56 Disconnect I left the game. alServ2018 Coop c1m1_hotel

I am seeing the regular server loading screen at this time, but this connection attempt does not load the campaign. HLstatsX is showing c1m1_hotel at this time. During the 4 minutes between this entry and the last entry, the server has been unreachable in the game client:
2018-11-04 03:10:54 Connect I connected to the server. alServ2018 Coop dw_woods

The next entry shows that the game server has loaded c1m1_hotel after a 30 second load time into the server:
2018-11-04 03:11:24 Entry I entered the game. alServ2018 Coop c1m1_hotel


Connection dropped between maps:

Last kill before closing saferoom door on DW:E Map 2, connection dropped during kill summary screen:
2018-11-04 04:26:23 Kill I killed infected with knife. alServ2018 Coop dw_underground
Back to top Go down
View user profile
alBert2000
sprinting dead
sprinting dead
avatar


PostSubject: Re: server lags   2018-11-04, 10:51

I've extracted some log info from the Linux server.
The problem was the "data-check of RAID array md0".
It is configured by default to run on the first Sunday each month at 00:57.
I've changed that now so that it should happen on the first Wednesday each month.
So it should no longer disturb the weekend.
I hope that my change will stick so that it survives server updates.

Code:

Nov  4 00:57:01 h2378406 kernel: [234145.170945] md: data-check of RAID array md0
Nov  4 00:57:01 h2378406 kernel: [234145.170951] md: minimum _guaranteed_  speed: 1000 KB/sec/disk.
Nov  4 00:57:01 h2378406 kernel: [234145.170954] md: using maximum available idle IO bandwidth (but not more than 200000 KB/sec) for data-check.
Nov  4 00:57:01 h2378406 kernel: [234145.170959] md: using 128k window, over a total of 1023936k.
Nov  4 00:57:01 h2378406 mdadm[851]: RebuildStarted event detected on md device /dev/md/0
Nov  4 00:57:01 h2378406 mdadm[851]: RebuildFinished event detected on md device /dev/md/0
Nov  4 00:57:01 h2378406 mdadm[851]: RebuildStarted event detected on md device /dev/md/0
Nov  4 00:57:01 h2378406 kernel: [234145.378120] md: delaying data-check of md1 until md0 has finished (they share one or more physical units)
Nov  4 00:57:11 h2378406 kernel: [234155.624177] md: md0: data-check done.
Nov  4 00:57:11 h2378406 mdadm[851]: RebuildStarted event detected on md device /dev/md/1
Nov  4 00:57:11 h2378406 mdadm[851]: Rebuild99 event detected on md device /dev/md/0
Nov  4 00:57:11 h2378406 kernel: [234155.643401] md: data-check of RAID array md1
Nov  4 00:57:11 h2378406 kernel: [234155.643412] md: minimum _guaranteed_  speed: 1000 KB/sec/disk.
Nov  4 00:57:11 h2378406 kernel: [234155.643417] md: using maximum available idle IO bandwidth (but not more than 200000 KB/sec) for data-check.
Nov  4 00:57:11 h2378406 kernel: [234155.643426] md: using 128k window, over a total of 971736896k.
Nov  4 00:57:11 h2378406 mdadm[851]: RebuildFinished event detected on md device /dev/md/1
Nov  4 00:57:11 h2378406 mdadm[851]: RebuildStarted event detected on md device /dev/md/1
Nov  4 00:57:11 h2378406 mdadm[851]: RebuildFinished event detected on md device /dev/md/0
Nov  4 01:47:12 h2378406 mdadm[851]: Rebuild25 event detected on md device /dev/md/1
Nov  4 02:20:32 h2378406 mdadm[851]: Rebuild43 event detected on md device /dev/md/1
Nov  4 02:53:52 h2378406 mdadm[851]: Rebuild61 event detected on md device /dev/md/1
Nov  4 03:43:52 h2378406 mdadm[851]: Rebuild80 event detected on md device /dev/md/1
Nov  4 04:43:55 h2378406 kernel: [247759.400861] md: md1: data-check done.
Nov  4 04:43:55 h2378406 mdadm[851]: RebuildFinished event detected on md device /dev/md/1, component device  mismatches found: 896 (on raid level 1)

Disk IO because of RAID check on Linux server:

[You must be registered and logged in to see this link.]

RAID check is causing high iowait and system load in CPU diagram:

[You must be registered and logged in to see this link.]
Back to top Go down
View user profile
Snakecharmed
Walking dead
Walking dead
avatar


PostSubject: Re: server lags   2018-11-04, 18:34

That definitely explains the slow and erratic loading issues I noticed at that time. Since the cron job only runs once a month, that would be why I've never seen this happen before. Thanks for the update!
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: server lags   

Back to top Go down
 
server lags
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» No server response
» New online chess server, www.easychess.com
» Chess-Tournament-Results-Server
» FICS - Free Internet Chess Server
» No server response

Permissions in this forum:You cannot reply to topics in this forum
alServ2000 :: LEFT 4 DEAD 2 :: L4D2 Servers :: [L4D2] alServ2018 Coop-